支持NFS Multipathing的系统版本

23.03和23.09文档中都提到了,支持NFS Multipathing特性,但安装了23.09版本,没有对应的ko文件。

# modprobe nfs_multipath
modprobe: FATAL: Module nfs_multipath not found in directory /lib/modules/6.4.0-10.1.0.20.oe2309.aarch64

请问这个特性在哪个内核版本支持?

1 Like

23.03和23.09是明年24.03 LTS版本的创新版本,应该会在24.03 LTS上使用,内核为6.x

1 Like

你需要重新编译kernel,选中nfs_multipath选项,编译出ko文件来加载

b10d3e7fc4c244c8fb16a4d08dbe9b6
openeuler 23.09版本内核编译配置中没有找到对应配置,也没有找到对应模块的源码,请问您是基于哪个版本编译的?

我们这边主要用的是openEuler 23.03
installation-and-deployment (openeuler.org)

1 Like

内核需要加载multpath驱动

也遇到相同的问题,有找到多路径的编译选项吗?

请教下,能否帮忙提供个配置的截图?(也没有找到配置的地方) 多谢。