openEuler23.09还支持python2吗

求助各位大佬,openEuler23.09是不是不支持python2了呀 :thinking:

从 openEuler 22.03-LTS版本开始,停止支持和维护Python 2,如图所示:

官方文档也有明确说明: 用户须知 (openeuler.org)

2 Likes

可是很多年前的软件是用python2写的,那是不是就没法在新版本的系统上使用了,这个感觉不大合理

hhh 你也说“很多年前”了。
可以自己使用python2的源码编译,或者找现有的RPM。

可以去oepkg安装需要的python2包

没有python2 是不是不能使用firewalld啊,我安装了firewalld,然后提示我这个
image
去查找了一圈,网上说需要python2的支持,不知道有没有遇到同样问题的?

openEuler 默认就是 firewalld 防火墙,不用自己安装

不好意思,没表述全面,我是embedded 版本的openEuler,不过我看到了iptables :v: