openeuler 22.03 LTS有没有PHP 8.2的RPM包

近期很多PHP项目都要求采用PHP 8.2及以上版本,22.03默认是8.0版本,LTS版本哪里有RPM包下载。

1 Like

可以基于社区的php8.0的仓库,拉到自己的gitee,改下php源码包,利用社区的euler进行重新构建

官方的yum源只提供了基础功能支持,还有rpm包、第三方源可以扩展

我也遇到同样问题,希望通过dnf安装,你解决了吗

我今天构建了包,你添加一个repo,就可以安装了
[copr:eur.openeuler.openatom.cn:quanag_100:php-8.2]
name=Copr repo for php-8.2 owned by quanag_100
baseurl=https://eur.openeuler.openatom.cn/results/quanag_100/php-8.2/openeuler-22.03_LTS-$basearch/
type=rpm-md
skip_if_unavailable=True
gpgcheck=1
gpgkey=https://eur.openeuler.openatom.cn/results/quanag_100/php-8.2/pubkey.gpg
repo_gpgcheck=0
enabled=1
enabled_metadata=1

1 Like