x2工具升级失败,提示x2openEuler-upgrade install failed

故障描述:

x2工具升级失败,提示x2openEuler-upgrade install failed,如下图所示:
image

故障处理:

在待升级节点执行rpm -qa|grep x2openEuler,如下图所示:
image
此时发现待升级节点不仅安装了x2openEuler-client包,也同时安装了x2openEuler-core包(server端安装的包),这两个包不能同时安装在待升级节点,否则升级时报错。

在待升级节点执行以下命令卸载x2的core包:

rpm -e x2openEuler-core-xxx --nodeps
注意:xxx为版本号

包卸载完成后,点击回退按钮,然后重新进行升级。

2 Likes

:+1:

补充下,x2 630版本之后待升级节点上只会安装一个rpm包,就只有 x2openEuler-upgrade-1.1.3-33.x86_64.rpm

此话题已在最后回复的 24 小时后被自动关闭。不再允许新回复。