Requires-rsync大于3.1.0

Error:package:x2openEuler-upgrade-1.1.3-33.x86_64 (/x2openEuler-upgrade-1.1.3-33.x86_64)
Requires:rsync >3.1.0
You could try using --skip-broken to work around the problem
You could try running:rpm-Va --nofiles–nodigest
ERROR ]-[centos2openEuler]-[install]:x2openEuler-upgrade install failed,please run:yum install x2openEuler-upgrade.and retry

image

排查思路:

1、在待升级节点查看 /opt/x2openEuler-upgrade下面是否有x2openEuler-upgrade-1.1.3-33.x86_64.rpm

2、确定x2openEuler-upgrade-1.1.3-33.x86_64.rpm存在,通过下面的命令安装

yum install x2openEuler-upgrade-1.1.3-33.x86_64.rpm

执行这个命令报错如下:

image

3、执行yum search rsync确认repo源里面是否有rsync包,搜索结果如下,没有搜索到。

image

4、修改repo源。

1 Like