OpenEuler2203SP1版本离线安装UKUI不成功

根据 openEuler_UKUI_install_cn.md · openKylin-backup/ukui-issues - Gitee.com方案未能成功安装,文档基于欧拉20.03版本。
安装报错
Last metadata expiration check: 0:00:25 ago on Thu 18 Apr 2024 02:21:22 AM CST.
Error:
Problem 1: conflicting requests

  • nothing provides pulseaudio-devel needed by ukui-settings-daemon-common-1.2.1-1.x86_64
    Problem 2: conflicting requests
  • nothing provides pulseaudio-devel needed by ukui-settings-daemon-devel-1.2.1-1.x86_64
    Problem 3: package ukui-window-switch-2.0.2-1.x86_64 requires ukwm >= 1.1.0, but none of the providers can be installed
  • conflicting requests
  • nothing provides libgnome-desktop-3.so.17()(64bit) needed by ukwm-1.2.0-1.x86_64
    Problem 4: package ukui-settings-daemon-1.2.1-1.x86_64 requires ukui-settings-daemon-common, but none of the providers can be installed
  • conflicting requests
  • nothing provides pulseaudio-devel needed by ukui-settings-daemon-common-1.2.1-1.x86_64
    Problem 5: package ukui-panel-2.0.8-1.x86_64 requires libQt5XdgIconLoader.so.3()(64bit), but none of the providers can be installed
  • package ukui-panel-2.0.8-1.x86_64 requires libQt5Xdg.so.3()(64bit), but none of the providers can be installed
  • conflicting requests
  • nothing provides libQt5Gui.so.5(Qt_5.11.1_PRIVATE_API)(64bit) needed by libqtxdg-3.3.1-3.x86_64
  • nothing provides qt5-qtbase(x86-64) = 5.11.1 needed by libqtxdg-3.3.1-3.x86_64
    Problem 6: package ukui-control-center-2.0.2-1.x86_64 requires libKF5Screen.so.7()(64bit), but none of the providers can be installed
  • package libkscreen-qt5-5.15.5-1.x86_64 requires libKF5WaylandClient.so.5()(64bit), but none of the providers can be installed
  • conflicting requests
  • nothing provides qt5-qtbase(x86-64) = 5.11.1 needed by kf5-kwayland-5.55.0-1.x86_64
    (try to add ‘–skip-broken’ to skip uninstallable packages or ‘–nobest’ to use not only best candidate packages)
    error: Failed dependencies:
    xhost is needed by xorg-x11-xinit-1.4.0-4.x86_64
    xorg-x11-xauth is needed by xorg-x11-xinit-1.4.0-4.x86_64
    Last metadata expiration check: 0:00:35 ago on Thu 18 Apr 2024 02:21:22 AM CST.
    Error:
    Problem 1: conflicting requests
  • nothing provides libQt5Widgets.so.5(Qt_5.11.1_PRIVATE_API)(64bit) needed by peony-2.1.2-1.x86_64
    Problem 2: conflicting requests
  • nothing provides libQt5Gui.so.5(Qt_5.11.1_PRIVATE_API)(64bit) needed by qt5-ukui-platformtheme-1.0.3-1.x86_64
    (try to add ‘–skip-broken’ to skip uninstallable packages or ‘–nobest’ to use not only best candidate packages)
    Last metadata expiration check: 0:00:45 ago on Thu 18 Apr 2024 02:21:22 AM CST.
    Package ubuntukylin-default-settings-20.04.2-1.x86_64 is already installed.
    Dependencies resolved.
    Nothing to do.
    Complete!
    Last metadata expiration check: 0:00:56 ago on Thu 18 Apr 2024 02:21:22 AM CST.
    No match for group package “dejavu-sans-fonts”
    No match for group package “dejavu-sans-mono-fonts”
    No match for group package “dejavu-serif-fonts”
    No match for group package “smc-meera-fonts”
    No match for group package “thai-scalable-waree-fonts”
    Dependencies resolved.
    ===========================================================================================================================================================================
    Package Architecture Version Repository Size
    ===========================================================================================================================================================================
    Installing Groups:
    Fonts

Transaction Summary

Complete!

有无大佬能给个操作方案

找台能上外网的机器,把需要的包拉到本地,然后把包放到这台机器上来安装吧

1 Like

1、能上网的机器上通过下面的命令下载ukui所需要的包,保存到/root/soft(记得提前创建好目录):

yum install --downloadonly --downloaddir=/root/soft ukui

2、将能上网机器上/root/soft目录下的文件拷贝到需要安装ukui的机器上

3、在需要安装ukui的机器上面安装拷贝过去的包
进入ukui安装包所在目录后执行如下命令:

rpm -ivh *.rpm

4、ukui主机设置默认以图形界面启动

systemctl set-default graphical.target

5、重启ukui主机

reboot

6、验证ukui主机重启成功后是否出现图形界面