openEuler20.03sp3 如何将openssh降低到7.4版本

有没有大佬验证过openEuler20.03sp3 如何将openssh降低到7.4版本的具体操作呀 十分感谢!

OEPKGS-SEARCH提供了openssh 7.4,安装时候可能得注意不要和系统默认的软件源弄混了

1 Like

你好!具体的步骤可以方便说一下么 我rpm卸载原来的包,再用rpm安装找个 最后显示ssh服务不存在。

1 Like
dnf remove openssh
wget https://repo.oepkgs.net/openeuler/rpm/openEuler-20.03-LTS-SP3/contrib/others/x86_64/Packages/openssh-7.4p1-4.x86_64.rpm
rpm -hiv openssh-7.4p1-4.x86_64.rpm

你好!如果服务器是离线的无法链接互联网络,并且按要求也不能连接,这样的情况该如何操作呀。

那就把那个openssh-7.4p1-4.x86_64.rpm包下载在一台有网的机器上,然后拷到服务器上,再rpm -hiv openssh-7.4p1-4.x86_64.rpm安装。
安装的时候会需要其他软件包,根据提示,重复上面的过程,缺哪个安装哪个,不过这样很可能非常麻烦

1 Like

十分感谢!

1 Like