openEuler 22.03 LTS安装MariaDB 10.11?

资源介绍:
1、openEuler 22.03.LTS x86_64 位系统;
2、配置 maridb 官方 repo 仓库配置:Index of /yum/10.11/centos/8/x86_64/
命令执行:
1、dnf clean all
2、dnf makecache
3、dnf install MariaDB-server MariaDB-client
报错:
Error:
Problem: package MariaDB-server-10.11.7-1.el8.x86_64 requires galera-4, but none of the providers can be installed

  • cannot install the best candidate for the job
  • nothing provides libboost_program_options.so.1.66.0()(64bit) needed by galera-4-26.4.13-1.el8.x86_64

openEuler 操作系统上不能安装 el8 的包,官方目前支持到 10.5: OEPKGS-SEARCH

1 Like

官方确实是10.5的,10.11el7和el8的包安装都会出现类库的问题。项目需要的是10.11,如果没有好的解决方式,考虑用容器安装了

添加个wlnmp源,然后就可以直接yum install wmariadb1011安装了

谢谢,回头我来试一下!