openeuler20.03sp3离线rpm安装ipmitool,缺少依赖包net-snmp-agent去哪找?

局域网,无法在线yum,只能使用离线方案rpm安装ipmitool。相关的依赖包有ipmitool-help,net-snmp。但在安装net-snmp时依赖net-snmp-agent,在iso里找不到这个net-snmp-agent的rpm包,这个去哪里找?everythin的ios里也没有。

安装 net-snmp 有依赖 net-snmp-agent 吗?没有呀


image
[root@zwwwq-ebs1 ipmitool]# arch
aarch64
[root@zwwwq-ebs1 ipmitool]# cat /etc/os-release
NAME=“openEuler”
VERSION=“20.03 (LTS-SP3)”
ID=“openEuler”
VERSION_ID=“20.03”
PRETTY_NAME=“openEuler 20.03 (LTS-SP3)”
ANSI_COLOR=“0;31”

复现不了,我换了 aarch64 的 openEuler 20.03 LTS SP3 也没有报依赖问题:

另外,net-snmp 这个包你是不是自己编译过,导致的依赖检测失败,openEuler 的包怎么会去依赖 el8 的包(你的第二张图的 net-snmp-agent 就是 el8 的包)

1 Like

是存储厂商提供的openeuler的iso镜像,安装完系统默认就有net-snmp-agent的el8的包,有可能是三方厂商编译过

感觉ipmitool对net-snmp不是特别强依赖,我使用 rpm -ivh ipmitool-1.8.18-16.oe1.aarch64.rpm --nodeps强制安装上了。