安装x2openEuler工具之后,没有service_start.sh脚本

你那个目录下放的啥文件,rpm包是不行的
image
用上传软件包的方式呢?

1 Like

你好,无论是上传软件包还是扫描路径都不行,目前原因很难定位,安装过程也是跟着官网一步一步安装的

看了下日志,报错信息如下:

那应该没安装8.0版本支持包吧,版本选默认支持的centos8.2/openEuler20.03-LTS-SP1再试试

嗯呢,好的,谢谢,应该是的,我大概找到解决问题的思路了


你好麻烦再问下,更换后又报这个错误,是因为库版本不对吗

应该是的,你的部署环境换成centos7.6了没?

image
上面是我源操作系统版本8.2,我现在要升级为openEuler20.03-LTS-SP1

现在官网3.0版本只支持7.6升到openEuler20.03-LTS-SP1版本吗,那如果是8.2要单独下载包是吧

我说的7.6是指你部署升级工具的系统版本,另外8的应该只能升到openEuler22.03-LTS。
8的支持包在这里下载:Index of /rpm/openEuler-22.03-LTS/contrib/x2openEuler/noarch/Packages/
有三个:x2openEuler-database-openEuler22.03-LTS-2.0.0.630-1.noarch.rpm
另外两个包根据版本选择。如8.0版本
x2openEuler-database-centos8.0-2.0.0.630-1.noarch.rpm
x2openEuler-database-centos8.0-openEuler22.03-LTS-2.0.0.630-1.noarch.rpm

嗯,好的,谢谢了解了,还有一个疑问就是我部署x2openEuler工具的操作系统和待升级的操作系统可以是同一个操作系统吗,还是说要分开,因为我在尝试着系统升级的时候有个报错说我的待升级操作系统节点安装了x2openEuler,检测失败,是不是要分开是吧

1 Like

对,工具端不能升级
另外建议还有其他问题再开个帖子,“项目范围蔓延”有点大了

嗯,好的谢谢,有问题的话我再开个帖子

麻烦问下你说的这三个包是要安装在 x2openEuler工具所在的操作系统下吗,还是说是要安装在待升级节点的操作系统下

建议如datakit一样,带一个小数据库,加一个mariadb增加了复杂度