rpm离线部署软件时报错

操作系统 openEuler 22.03 (LTS-SP2)arrch64
报错mono(System.Web.Extensions) = 4.0.0.0 被 mono-web-6.12.0-5.el9.aarch64 需要,请问该怎么处理

有没有版主帮忙看看

有截图吗,看样子是缺少依赖

安装mono(System.Web.Extensions) = 4.0.0.0这个依赖所在rpm包

是缺少依赖。需要继续安装mono,还是下载rpm包,用dnf install安装mono的rpm包,其他依赖同理

不知道这个依赖哪个包

需要离线安装 不知道这个mono(System.Web.Extensions) = 4.0.0.0依赖那个软件包

mono-web这个软件在社区是没有构建的,是需要在openEuler22.03-LTS-SP2上构建的,你使用的是el9的包

社区是没这个包 找不到mono对应的依赖包

我看下能不能给编译一个,能编译我会贴出来

不知道mono在openEuler22.03-LTS-SP2对应centos哪个版本的包,这是我在http://rpmfind.net/搜索下的包,安装时提示报错”mono(System.Web.Extensions) = 4.0.0.0 被 mono-web-6.12.0-5.el9.aarch64 需要“,下面是需要装的mono的全家桶

1 Like

欧拉好多rpm包不能用centos的。感觉是走了一条差异渐远的路