任务执行异常,异常原因 : execute failed

计划将centos7.8更新至openeuler22.03-LTS版本,但执行收集与评估报标题中的错误,日志如下,请各位大佬指点:
2024-01-05 11:17:10 Fri|23924:140421905168128|env_check_scheduler.py:200|_analyse_actor_result|INFO|[{‘actor_name’: ‘CheckTargetConActor’, ‘actor_description’: ‘检查连通性,返回连通性检查判断条件’, ‘actor_priority’: ‘mandatory’, ‘actor_result’: True, ‘actor_solution’: ‘try ssh connect success’, ‘failed_reason’: ‘try ssh connect success’}, {‘actor_name’: ‘CheckOpenEulerCorePackageActor’, ‘actor_description’: ‘检查目标节点是否有安装x2openEuler-core包,防止使用当webserver的节点又做升级节点’, ‘actor_priority’: ‘mandatory’, ‘actor_result’: True, ‘actor_solution’: ‘目标节点没有安装x2openEuler-core包’, ‘failed_reason’: ‘待升级节点没有安装x2openEuler-core包’}, {‘actor_name’: ‘CheckTargetArchActor’, ‘actor_description’: ‘获取目标节点的架构信息’, ‘actor_priority’: ‘mandatory’, ‘actor_result’: True, ‘actor_solution’: ‘从目标节点获取arch信息成功,SUCCESS’, ‘failed_reason’: ‘’}, {‘actor_name’: ‘LibsolvCheckActor’, ‘actor_description’: ‘检查目标节点是否安装了libsolv,若安装了,检查libsolv版本是否大于等于7’, ‘actor_priority’: ‘mandatory’, ‘actor_result’: True, ‘actor_solution’: ‘run the command: yum upgrade libsolv’, ‘failed_reason’: ‘’}, {‘actor_name’: ‘InstallRpmPackageActor’, ‘actor_description’: ‘install client&upgrade rpm package’, ‘actor_priority’: ‘mandatory’, ‘actor_result’: True, ‘actor_solution’: ‘install rpm package SUCCESS’, ‘failed_reason’: ‘’}]
2024-01-05 11:17:10 Fri|23924:140421905168128|env_check_scheduler.py:207|_run_actors|INFO|running actor:CheckUpgradeNode
2024-01-05 11:17:10 Fri|23924:140421923264256|actor_thread.py:24|run|INFO|run in <class ‘taskmanager.actors.env_check_actor.upgrade_node_check_actor.CheckUpgradeNode’>
2024-01-05 11:17:10 Fri|23924:140421923264256|try_connect.py:21|try_login|INFO|auth type is:password_auth
2024-01-05 11:17:10 Fri|23924:140421923264256|utils.py:168|_ssh_login_and_change_root|INFO|ssh_client login successfully
2024-01-05 11:17:10 Fri|23924:140421923264256|try_connect.py:42|try_login|INFO|now login as root!
2024-01-05 11:17:10 Fri|23924:140421923264256|try_connect.py:48|try_login|INFO|in node < id:3 ip:10.228.197.49 > ,try ssh connect finish
2024-01-05 11:17:10 Fri|23924:140421923264256|upgrade_node_check_actor.py:142|run|INFO|start check upgrade node in node < id:3 ip:10.228.197.49 >
2024-01-05 11:17:11 Fri|23924:140421923264256|upgrade_node_check_actor.py:73|execute_cmd|INFO|start to execute command [x2openEuler-upgrade-check pre-env-check -er /opt/x2openEuler-upgrade/output/upgrade-check/pre-env-check-node-2bac645c-5019-4616-afa4-e312cd0b88de.json]
2024-01-05 11:17:11 Fri|23924:140421923264256|utils.py:95|send_nohup_command_universal|INFO|send nohup command by root user
2024-01-05 11:17:12 Fri|23924:140421923264256|utils.py:109|get_remote_log_by_nohup_universal|INFO|get nohup log by root user
2024-01-05 11:17:23 Fri|23924:140421923264256|upgrade_node_check_actor.py:113|download_remote_env_check_report|INFO|copy the report at the remote /opt/x2openEuler-upgrade/output/upgrade-check/2bac645c-5019-4616-afa4-e312cd0b88de/pre_env_check-2bac645c-5019-4616-afa4-e312cd0b88de.json to the

1 Like

工具是哪个版本呢?能否提供完整的日志信息呢?

工具版本为:x2openEuler-core-3.0.0-20231012,有日志信息(zip格式),但好像不能上传吧?没有找到上传附件的方法呢!