升级阶段缺少libpython3.9.so.1.0报错

一、问题描述
升级阶段出现报错缺少libpython3.9.so.1.0,如图

二、问题分析
经查看,该lib库在/usr/local/x2openEuler-python/lib/下
且root用户~/.bashrc中有相关环境变量,如图


经排查发现,root用户~/.bash_profile中存在异常环境变量,由于.bash_profile优先级高于.bashrc,导致在升级时无法找到相关lib库

三、问题解决
注释掉root用户~/.bash_profile中的错误环境变量后重试即可。

6 Likes

好贴必赞!

1 Like

930版本对这个问题进行了规避,可以使用最新的930版本